[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

makefile changes ignored

From: angelo
Subject: makefile changes ignored
Date: Thu, 03 Dec 2009 10:06:10 +0100
User-agent: Thunderbird (Windows/20090812)

Dear all,

i am having a very strange issue with make on OSX Leopard. This issue anyway is probably related to the operative system someway, but i try to explain.

Problem happen actually with GNU-Make 3.79.1 or 3.81

I have a Makefile with a target. Doing changes on it and executing again "make target" generally works. Some time, for some unknown reason, generally after an error while making is happen, any further changes on the makefile are ignored from make, and i still get the previous make output, like if i didn't make any changes on the makefile.

I try to reboot, the makefile is modified, but i still get the old output, before the makefile was modified.

It seems that the old Makefile is cached someway and is still used instead of the new.

Thanks in advice.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]