[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


From: branganj
Subject: octfiles
Date: Tue, 1 Apr 2003 18:20:03 +0100

Hi, thank you for all your help; I have fixed some things:

I read in the octave_value_list as a Matrix , using .matrix_value, which I see 
is a function in the file ov.h (of the class octave_value)
Have I used it right?

I still get this error:, but it creates the .oct file
cit-templates -g -O2 -Wall -o mpi_mm.o In function `class octave_value_list Fmpi_mm(const class 
octave_value_list &, int)': warning: unused variable `int nbytes' warning: control reaches end of non-void function 
`Fmpi_mm(const octave_value_list &, int)'
-shared -o mpi_mm.oct mpi_mm.o

>a = rand(62,15)  /the code worked before with matrices of these sizes - there 
is no segmentation fault now . i obviously haven't yet accounted for all types 
of matrices

>b = rand(15,7)

octave:3> mpi_mm([a,b],0)
error: number of rows must match near line 3, column 11
error: evaluating argument list element number 1
error: evaluating index expression near line 3, column 1

The above is the error I get when trying to execute the function.
Is there some problem with the reading in off the octave_value_list?

Also, can I just ask does anybody know how I can change the LOADPATH variable?
 I wasn't sure because normally I would add it to the bashrc file, but as its 
octave, I dunno.  Anyhow, I did with OCTAVE_PATH=$OCTAVE_PATH:/.....the path, 
but that didn't work.
Because, before I wasn't sure about how to change the LOADPATH, so I just put 
.oct files in the DEFAULT_LOADPATH and that seemed to work, but now for some 
weird reason, I get errors for some of the .oct files  saying it can't load it 
from there.  Is this just sth weird with the cluster and might work later 

Thanks for helping,

Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]