[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Cannot draw figures in Mac OS X

From: Henry F. Mollet
Subject: Re: Cannot draw figures in Mac OS X
Date: Thu, 19 Feb 2004 15:55:56 -0800
User-agent: Microsoft-Entourage/

My Fink Octave installation has the application in /sw/bin/octave-2.1.46
(66.6 MB) and next to it an alias file /sw/bin/octave (4 kB).

Therefore the application is covered by the EXEC_PATH?
octave:2> EXEC_PATH
EXEC_PATH= :/sw/bin:/sw/sbin:/bin:/sbin:/usr/bin:/usr/sbin:.:/usr/X11R6/bin

On my Fink installation the minimum settings in .cshrc and .octaverc appear
to be the following:

[~] tcsh:14> cat .cshrc
# Setting Path for Fink Usage
# But source executes a CShell script
source /sw/bin/init.csh

[~] tcsh:15> cat .octaverc
%% My octaverc
LOADPATH = [LOADPATH, ":/sw/share/doc/octave/examples/"];
% ":" stands for the default loadpath, which takes care of everything else I
need, I think.  I deleted the ":" once and nothing worked any longer.

[~] tcsh:17> octave
% I believe octave is an alias for octave-2.1.46 in my case
GNU Octave, version 2.1.46 (powerpc-apple-darwin6.8).


The last item covers "sombrero (n)", I think. Not sure what the other ones
are for. The default loadpath did not cover the example oregonator.m and .cc
and I had to cover this in my .octaverc.

On 2/18/04 4:18 PM, "Joe Koski" <address@hidden> wrote:

> on 2/18/04 3:21 PM, Vic Norton at address@hidden wrote:
>> Hi Joe,
>> I've been using Octave 2.1.50 for a while now. I installed it through
>> DarwinPorts. My system is Mac OS X 10.3.2. Everything works fine, but
>> I've never tried to graph anything. Nor have I ever used X11 in any
>> way.
>> Your instructions looked so simple. I thought I'd try them. I didn't
>> get very far. I opened X11 (and the xterm application) and wrote:
>>   vic$ octave
>>   bash: octave: command not found
>> OK, X11 doesn't know where octave is. Well, I don't have any idea of
>> how to start X11 with octave in its path, so I'll just append the
>> appropriate directory on the fly:
>>   vic$ PATH=$PATH:/opt/local/bin
>>   vic$ export PATH
>>   vic$ octave
>>   GNU Octave, version 2.1.50 (powerpc-apple-darwin7.2.0).
> My octave was installed via fink, and when I type "octave" at the xterm or
> prompt, I get octave. I don't know how darwinports sets things
> up. You probably need to set up an alias in an appropriate (on your system)
> resource file (.cshrc, .bashrc, .xinitrc, etc.) to make just "octave" work
> anywhere.
>>   ...
>>   Report bugs to <address@hidden>.
>>   octave>
>> So far so good. Now to try your instructions:
>>   octave> x = rand(1:3);
>>   octave> y = rand(1:3);
>>   octave> plot(x,y);
>>   octave>
>> Well, that's it. That's my random plot, Joe. You are seeing everything.
> You may need to enter
> gset term X11
> to tell gnuplot to open X11 windows. Otherwise I don't know what to do.
> Also, try
> gset term aqua
> To see if Aquaterm is installed. It has some advantages over X11 (easy save
> to .pdf).
> Good luck.
> Joe Koski
> -------------------------------------------------------------
> Octave is freely available under the terms of the GNU GPL.
> Octave's home on the web:
> How to fund new projects:
> Subscription information:
> -------------------------------------------------------------

Octave is freely available under the terms of the GNU GPL.

Octave's home on the web:
How to fund new projects:
Subscription information:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]