[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

copyfile() not working on my new Win7 PC

From: Tim Rueth
Subject: copyfile() not working on my new Win7 PC
Date: Tue, 28 Sep 2010 00:00:48 -0700

I recently got a new Windows 7 PC and installed Octave 3.2.3 on it.  I ran one of my tried-and-true scripts on it, and I get an odd message when it tries to execute a copyfile() instruction near the end of the script.  Here are relevant parts of the code:
tempfile = ["temp.txt"];
fid = fopen(tempfile, "wt");
foo = 10;
<write some stuff to the file>
resfilename = ["thisrun" num2str(foo,"%2d") ".txt"];
When I run this script on my Vista machine, it runs fine.  But when I run it on my Win7 machine, this is what I get right after the copyfile command is executed:
         0 [main] us 0 init_cheap: VirtualAlloc pointer is null, Win32 error 487
AllocationBase 0x0, BaseAddress 0x71110000, RegionSize 0x290000, State 0x10000
C:\Octave\3.2.3_gcc-4.4.0\MSYS\bin\cp.exe: ***Couldn't reserve space for
cygwin's heap, Win32 error 0
So, it looks like it couldn't copy the file because it couldn't reserve space for cygwin's heap.  Not sure what that means or what I can do to fix it.  Note, tempfile is not a large file.  Any help would be greatly appreciated.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]