[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: testing binaries octave-3.4.2 on MinGW

From: Philip Nienhuis
Subject: Re: testing binaries octave-3.4.2 on MinGW
Date: Wed, 29 Jun 2011 01:13:02 +0200
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20100701 SeaMonkey/2.0.6


Tatsuro MATSUOKA wrote:

(2) In the octave binary, pcre3.dll is missing (e.g., "help foo" complains 
about it).
Easily fixed by copying it over from 3.3.91 version or from one of the other 
zip files (gnuwin32).

(3) Installing packages doesn't work because gzip.exe cannot be found:
"'gzip' is not recognized as an internal or external command,
operable program or batch file."
But it IS in the path, in the .\shared\...\miscellaneous subdir, and I copied 
the exe in the \bin directory.

Thank you for your pointed out. I will fix them.

I have corrected the package and uploaded in the web.

As to the development environment:
(4) Do you have an outline of what files to put where, and what environment 
settings we should set up?

OK I will add the description my build command setting to ReadMe.
  I have add some  descriptions to Readme_octave-3.4.2.txt.

Thank you again  for your quick response.

Some more:

I repeated extracting, now at my home PC into C:\Programs\Octave\3.4.2
I put mingw... & msys.... under the 3.4.2 directory.
Next I moved several directories from gnuwin32, gplib, msys..., mingw.... etc into place in the \bin, \lib, \include, \msys\bin directories (I'll report later what I did). After a few tries, I could compile the java-1.2.8.tar.gz package; it worked flawlessly. Compiling the windows package didn't work - I hit these same error messages years ago too, I think the package needs adaptation to 3.4.2.

The line inserts in path command I reported don't occur anymore => fixed I guess.

Trying "help oct2xls" shows many "^M" symbols => I think the texinfo isn't properly compiled for CRLF line endings.

BTW octave-3.4.2 takes about 30 seconds to start on my 2.5 Ghz Core Duo, this is fairly long compared to 3.2.4.

The edit.m command (in .\miscellaneous) complains about unrecognized \P \O \3 sequences, apparently it incorrectly processes C:\Programs\Octave\3.4.2. I used the octaverc from the 3.2.4 binary, that may need adaptation.

And Benjamin used a trick to append or prepend the mingw\bin and msys\bin directories to the windows path - but this doesn't work. I start Octave using a batch file where I set these path entries first.

Hopefully I have more time later this week.

Nice work, Tatsuro! Thanks for this.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]