[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: MAC and GNU Plot - Help Please

From: Wesley Davis
Subject: Re: MAC and GNU Plot - Help Please
Date: Sun, 25 Sep 2011 08:51:51 -0400

Hey Guy's,

Thanks for your help,  However, I got some help from another guy named Stu on the board and he gave me the following procedure that worked over night.

First off, there are environmental variables that need to be set correctly.   At the command line:

cd ~
touch .bashrc
open .bashrc

The second line creates .bashrc if it doesn't already exist.  An editor should pop up. Put the following into it, save and quit:

export PATH=$PATH:/usr/local/bin
export GNUTERMAPP=/Applications/
export GNUTERM=aqua

To make bash aware of these new settings, you must make it re-read the .bashrc file.  An easy way of doing that is running the following command:

source .bashrc

With that take care of, there is only one more thing we need to do.  If you were to run Octave now and tried to  make it plot something, you'd get an error message saying it can't find libaquaterm.1.0.0.dylib.  The reasonit can't find this library, is that you've got a newer version, namely libaquaterm.1.0.1.dylib (at the time of writing).  To fix this , create a link like so:

cd /usr/local/lib
sudo ln -s libaquaterm.1.0.1.dylib libaquaterm.1.0.0.dylib "

[Note - I would try to plot before setting this link - it may not be necessary on later versions .....]

Test the installation with this at the command line:


An AquaTerm window should open and display the test result


On Sun, Sep 25, 2011 at 4:18 AM, Liam Groener <address@hidden> wrote:

On Sep 24, 2011, at 6:57 PM, Ben Abbott wrote:

I'm using maports. You can install the most recent Octave by ...

sudo port install octave-devel
I would recommend you make this:

           sudo port install octave-devel +fltk

Also, if you are using Lion, this will fail on your first try. Then open the file:
in an editor and add the line:
to the list of other "withouts." Then re-issue the install command. 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]