[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Video package not working

From: Andreas Weber
Subject: Re: Video package not working
Date: Thu, 09 Apr 2015 19:13:11 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Icedove/31.5.0

On 09.04.2015 18:35, JohnD wrote:
Message: 4
Date: Thu, 9 Apr 2015 13:32:24 +0400
From: Nasreen P <address@hidden>
To: address@hidden
Subject: Video package not working
Content-Type: text/plain; charset="utf-8"

Dear Developers,

I am working on my academic project and I want to convert the Matlab
in Ocatave. I tried to read the video in octave and it is showing error
Libaavformat missing error.

It sounds like you are missing avformat library?
What version of octave are you using? What OS.

Is using the video package in octave, it appears in the unmaintained list,
which probably will mean that that the state of the package may not be good.

I tried to build the current video repository on Debian wheezy (stable) with one patch that remove the deprecated allocator:
diff -r 31b9a4c9ad97 src/
--- a/src/        Tue Sep 03 07:50:42 2013 -0400
+++ b/src/        Thu Apr 09 19:11:34 2015 +0200
@@ -26,7 +26,6 @@
 #include <octave/oct.h>
 #include "oct-avifile.h"

 DEFINE_OV_TYPEID_FUNCTIONS_AND_DATA(Avifile, "avifile", "avifile");

 Avifile::Avifile(std::string fn) : octave_base_value(),
diff -r 31b9a4c9ad97 src/oct-avifile.h
--- a/src/oct-avifile.h Tue Sep 03 07:50:42 2013 -0400
+++ b/src/oct-avifile.h Thu Apr 09 19:11:34 2015 +0200
@@ -57,7 +57,6 @@
   unsigned int frame_rows;
   unsigned int frame_columns;


hg clone octave-video
sudo apt-get install libavformat-dev libswscale-dev
cd octave-video/src

After that the tests in,, runs fine

reply via email to

[Prev in Thread] Current Thread [Next in Thread]