[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

'imread()' cannot be used on Octave 3.8.2

From: hajime
Subject: 'imread()' cannot be used on Octave 3.8.2
Date: Sun, 12 Apr 2015 23:25:59 +0900

I got an error below when I was trying to use imiread function. 

octave:2> img = imread('IMG_0616.jpg') 
error: default_formats: /usr/local/octave/3.8.2/lib/octave/3.8.2/oct/x86_64-apple-darwin13.4.0/__magick_read__.oct: failed to load: dlopen(/usr/local/octave/3.8.2/lib/octave/3.8.2/oct/x86_64-apple-darwin13.4.0/__magick_read__.oct, 2): Symbol not found: __ZN6Magick5ColorC1Ejjj 
Referenced from: /usr/local/octave/3.8.2/lib/octave/3.8.2/oct/x86_64-apple-darwin13.4.0/__magick_read__.oct 
Expected in: /usr/local/octave/3.8.2/lib/libGraphicsMagick++.3.dylib 
in /usr/local/octave/3.8.2/lib/octave/3.8.2/oct/x86_64-apple-darwin13.4.0/__magick_read__.oct 
error: called from: 
error: /usr/local/octave/3.8.2/share/octave/3.8.2/m/image/imformats.m at line 255, column 11 
error: /usr/local/octave/3.8.2/share/octave/3.8.2/m/image/imformats.m at line 78, column 3 
error: /usr/local/octave/3.8.2/share/octave/3.8.2/m/image/private/imageIO.m at line 60, column 7 
error: /usr/local/octave/3.8.2/share/octave/3.8.2/m/image/imread.m at line 107, column 30 

I tried installing Octave 3.8.0, then it worked. 
What should I do to use imiread function on Octave 3.8.2 ? 

P.S. (How I installed Octave 3.8.2)

I just installed Octave 3.8.2 from 'Octave Forge' (the link is shown below). 

Then, I opened 'Octave-3.8.2-1.mpgk', clicked 'continue, continue, install', and the monitor showed 'installation completed', then clicked 'close'. 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]