[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: graphics_toolkit qt

From: Clinton Winant
Subject: Re: graphics_toolkit qt
Date: Sun, 17 Jul 2016 17:09:31 +0100

Still a bug, but ????

I am using:
GNU Octave, version 4.0.0
Copyright (C) 2015 John W. Eaton and others.
This is free software; see the source code for copying conditions.
FITNESS FOR A PARTICULAR PURPOSE.  For details, type 'warranty'.

Octave was configured for "x86_64-pc-linux-gnu".

OS:  ubuntu 16.04 - 64 bit

When I run the code you posted, things that are different from what you have, occur:

(1) The text line only produces centered text if I use
text (2, 0.5, "\lambda is a greek letter", "horizontalalignment", "center")

ie the x location must be within the frame generated by the plot command, even with the "horizontalalignment" modifier.
(2) In that case, the string \lambda appears on the screen as "lambda", however if the double quotes are replaced by single quotes:
text (2, 0.8, '\lambda is a greek letter', "horizontalalignment", "center")
the \lambda produces the greek character.  I conclude that in qt the generation of the proper greek character is determined by the use of single quotes rather than double quotes.  Notice that in the latex file included in your message there is no text, presumably because of point (1).

The first and last lines of the latex files generated on my system are as follows:

% Title: glps_renderer figure
% Creator: GL2PS 1.3.8, (C) 1999-2012 C. Geuzaine
% For: Octave
% CreationDate: Sun Jul 17 16:47:04 2016

The preable and end lines are consistently not generated on my system. Might the problem be associated with my using 4.0.0?  If so, since the ubuntu 16.04 repos don't have 4.0.1 yet,  can you point me to a set of instructions on how to configure, make and make install for octave source?

Thanks so much to all of you​

On Sun, Jul 17, 2016 at 3:37 AM, Ben Abbott <address@hidden> wrote:
> On Jul 16, 2016, at 5:56 PM, Ben Abbott <address@hidden> wrote:
> On Jul 15, 2016, at 04:45, Clinton Winant <address@hidden> wrote:
>> BTW the .tex file produced by
>>  print("qt_greek.tex","-depslatexstandalone");
>> does not compile with current version of latex.  The file requires the preamble
>> \documentclass{article}
>> \usepackage{graphicx,xcolor}
>> \begin{document}
>>  and the closing statement
>> \end{document}
> That's a bug. Can you file a bug report?
> Ben

opps! Maybe not a bug. I tried a simple example using the developer’s sources (default branch).

graphics_toolkit qt
plot (rand (3))
text (0.5, 0.5, "\lambda is a greek letter", "horizontalalignment", "center")
print ("qt_greek.tex", "-depslatexstandalone”);

The tex output is below.

% Title: gl2ps_renderer figure
% Creator: GL2PS 1.3.9, (C) 1999-2015 C. Geuzaine
% For: Octave
% CreationDate: Sat Jul 16 22:28:37 2016


reply via email to

[Prev in Thread] Current Thread [Next in Thread]