[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [help-texinfo] Changing fonts (default one doesn't support accents)

From: Karl Berry
Subject: Re: [help-texinfo] Changing fonts (default one doesn't support accents)
Date: Sat, 16 Dec 2006 19:58:26 -0600

Hi Nicolas,

    > >The text file is ISO-8859-15. I don't use the texinfo commands, because
    > >that makes the texfile almost unreadable. It's written in French, and
    > >there're a ton of accents.

I believe the latest will get you close to
the right output (as well as Computer Modern can do) for
@documentencoding ISO-8859-15
I just integrated Paulo's patch for that.  (And -1 and -2.  UTF-8 coming
soon, thanks to Werner and Oleg.)


1) hyphenation will be incorrect.  To get that right, you have to run a
   version of TeX with the French hyphenation patterns as the default,
   or otherwise arrange for it to happen.  And even then, accented words
   will not be hyphenated :(.

2) I doubt the pre-accented letters can be used in node names.  The only
   way I have heard of people successfully doing that is to use the
   Texinfo commands (@'e) and then use makeinfo --commands-in-node-names.

3) Another possibility is to use texi2dvi --recode to run the recode
   program to conver the input from the @documentencoding to Texinfo.
   I'm not sure how well it works.  If you try it, I'm interested to hear.

3) Better support for encodings and fonts has been mostly written
   (thanks to Oleg) but is not complete, and probably won't be
   finished and integrated before next summer.

Hope this helps,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]