[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [igraph] problem reading .net file

From: Gabor Csardi
Subject: Re: [igraph] problem reading .net file
Date: Thu, 12 Apr 2007 19:15:07 +0200
User-agent: Mutt/1.5.12-2006-07-14


thanks for reporting this, it is actually a bug. 

To correct it you can modify line 1940 in src/foreign-pajek-parser.c
    { igraph_pajek_directed=0; }
    { igraph_pajek_directed=1; }

I can send you a corrected R package (source or binary) if you
don't build R from source or don't know how to do the change above.

Another (dirty) workaround would be 
g[[2]] <- TRUE 
after reading the graph from the file. I think this works for the 
0.3.3 version, it definitely won't work from 0.4. I've tried for the 
.net file you've sent, it works for that. But this is a very dirty 
thing since it assumes that igraph stores the edges in exactly the 
same order as in the .net file.


On Thu, Apr 12, 2007 at 06:50:52PM +0200, Simone Gabbriellini wrote:
> btw, can you tell me also why, after importing the net file, I have:
> > is.directed(g)
> [1] FALSE
> while the .net file represent a directed graph?
> sorry to trouble you with this silly questions, but I would like to  
> learn igraph, cause it seems the smartest way to use R for quite  
> medium network (I am studying an online community made by 800 nodes)..
> thank you,
> Simone

Csardi Gabor <address@hidden>    MTA RMKI, ELTE TTK

reply via email to

[Prev in Thread] Current Thread [Next in Thread]