[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Info-AUCTeX] AUCTeX 11.81 with preview-latex released

From: David Kastrup
Subject: [Info-AUCTeX] AUCTeX 11.81 with preview-latex released
Date: Mon, 26 Sep 2005 11:59:51 +0200
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.0.50 (gnu/linux)

Release notes for AUCTeX 11.81 with preview-latex

AUCTeX provides by far the most wide-spread and sophisticated
environment for editing LaTeX, TeX, ConTeXt and Texinfo documents with
Emacs or XEmacs.  Combined with packages like RefTeX, flyspell and
others it is pretty much without peer as a comprehensive authoring
solution for a large variety of operating system platforms and TeX
distributions.  It supports document-dependent completion and syntax
highlighting, easily accessible menus, jumping to error locations in
the source file, a number of editing shortcuts, intelligent
indentation and filling of the text during entry, and WYSIWYG previews
of graphical elements like math formulas right in the Emacs source
buffer, by virtue of its preview-latex component.

One part of the preview-latex subsystem is the central `preview.sty'
file that is independently useful for a number of applications and is
available in unbundled form from CTAN.[1]

Interfaces and installation procedures in this release remain a moving
target.  If you feel you need to consult third-party installation
instructions for some reason, be sure that they refer to the same
version of AUCTeX as you are installing.  For installing AUCTeX
itself, the installation instructions in the AUCTeX package should be

AUCTeX needs volunteers in particular for non-programming tasks:
documentation writing, tutorials, translations, reference material,
sleuth work, testing.

New features and fixed bugs in this release

The most important feature of AUCTeX 11.81 is the inclusion of the
preview-latex subsystem, previously available separately.  There is no
documented provision for building or installing preview-latex
separately.  It is still possible to use and install AUCTeX without
preview-latex, however.

The installation procedures have been overhauled and now also install
startup files as part of the process (those had to be copied manually
previously).  You are advised to remove previous installations of
AUCTeX and preview-latex before starting the installation procedure.
A standard installation from an unmodified tarball no longer requires
Makeinfo or Perl.

Other new features include support for commands of the babel package,
generalization of language-specific quotation mark and hyphen
insertion, and tooltips for folding mode.

Of course, a lot of bugs have been fixed as well, such as problems
with filling Japanese text.

The encoding support of preview-latex has been further improved: it
should be able to deal with most encoding systems including utf-8

More detailed information can be found in the CHANGES file included in
the distribution or the "Changes" section in the manual.

IMPORTANT: Many of the new features in the 11.x series rely on special
properties in the variable `TeX-command-list' and will not work if you
customized this variable for a pre-11.5x release of AUCTeX.  If this
is the case for you, please re-initialize the variable by erasing the
customization, thereby setting the variable to the new default, and
re-adding your changes afterwards.


It is required that you use at least GNU Emacs 21 or XEmacs 21.4.
XEmacs requires at least version 1.84 of the xemacs-base package
(released on 01/27/2004) or a sumo tarball dated 02/02/2004 or newer
for compiling AUCTeX: please use the XEmacs package system for
upgrading if necessary.  Warning: release 21.4.16 of XEmacs is
severely broken.  This leads to crashes and hangs; don't use it.

The preview-latex subsystem requires image support.  This is available
with GNU Emacs 21.3 under the X window system.  For Windows[2], MacOS
Carbon[3] or native GTK+ toolkit support[4], a developer version[5] of
GNU Emacs (to be released as 22.1) is definitely required.  A recent
developer version of GNU Emacs appears like the best choice even on
X11, however.  If you prefer XEmacs-21, it will work in version
21.4.10 or later.

You'll also need a working LaTeX installation and Ghostscript.
dvipng[6] (version 1.4 or later: teTeX-3.0 works, TeXlive2004 not), a
very fast dvi converter, can be used to speed up the conversion.


AUCTeX can be downloaded in various formats from
<URL:>.  A separate directory
contains some stuff from the tarball, such as ChangeLog, printable
manuals, and a reference sheet.  The download area is mirrored to the
directory support/auctex on CTAN.  AUCTeX is licensed under the GNU
General Public License version 2.

You'll find more information at the web site of AUCTeX
<URL:>, including its mailing list

Future development and additional information

AUCTeX is proceeding as a GNU project with the long-term intent of
merging it into Emacs.  For that reason, all new contributors need to
assign copyright to their contributions to the FSF (the usual
procedure for Emacs contributors).  The same holds for past
contributors.  The principal authors and maintainers have already done
so, but it would require a diligent and diplomatic volunteer to find
and ask the rest.

Current project manager is David Kastrup.  While Paypal contributions
to <URL:mailto:address@hidden> are appreciated, volunteering for tasks
remains the most effective way of helping AUCTeX development.

The following people contributed to this release series (in
alphabetical order): Ralf Angeli, Masayuki Ataka, Thomas Baumann,
Berend de Boer, Miguel Frasson, Peter S. Galbraith, Patrick Gundlach,
Yvon Hevel, David Kastrup, Ikumi Keita, Frank Küster, Jan-Åke Larsson,
Dan Nicolaescu, Piet van Oostrum, Davide G. M. Salvetti, Mike Sperber,
Reiner Steib, Christian Schlauer, Shiro Takeda (Please accept our
apologies if we forgot somebody.)


[1]  <URL:>

[2]  You can get a precompiled version of CVS Emacs for Windows at
<URL:> or

[3]  <URL:>
contains build instructions.

[4]  Debian provides precompiled GTK+ Emacs packages in its `unstable'
distribution (look for `emacs-snapshot-gtk').  Packages for Fedora can
be found at <URL:>.

[5]  If making use of the precompiled variants is not an option for
you, instructions for checking out the CVS version straight from the
GNU's mouth can be found at

[6]  dvipng is available via its project page
<URL:> and from CTAN.

David Kastrup, Kriemhildstr. 15, 44793 Bochum

reply via email to

[Prev in Thread] Current Thread [Next in Thread]