info-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

.#files left after `cvs init'


From: Alexey Mahotkin
Subject: .#files left after `cvs init'
Date: Sun, 3 Jun 2001 18:13:25 +0400 (MSD)

When creating repositories with `cvs init' there are lots of backup
files left with names like '.#modules'.  Is this a bug or a feature? 

I consider this bug (if that's really "backup files", then they should
be more clearly named as such).  I think that either this patch should
be applied:

Index: mkmodules.c
===================================================================
RCS file: /home/cvsroot/cvs/src/mkmodules.c,v
retrieving revision 1.1.1.6
diff -u -u -r1.1.1.6 mkmodules.c
--- mkmodules.c 2001/05/19 12:05:04     1.1.1.6
+++ mkmodules.c 2001/06/03 14:06:55
@@ -802,11 +802,6 @@
     bak = xmalloc (strlen (real) + sizeof (BAKPREFIX) + 10);
     (void) sprintf (bak, "%s%s", BAKPREFIX, real);
 
-    /* rm .#loginfo */
-    if (unlink_file (bak) < 0
-       && !existence_error (errno))
-       error (0, errno, "cannot remove %s", bak);
-
     /* mv loginfo .#loginfo */
     if (CVS_RENAME (real, bak) < 0
        && !existence_error (errno))
@@ -816,6 +811,11 @@
     if (CVS_RENAME (temp, real) < 0
        && !existence_error (errno))
        error (0, errno, "cannot rename %s to %s", temp, real);
+
+    /* rm .#loginfo */
+    if (unlink_file (bak) < 0
+       && !existence_error (errno))
+       error (0, errno, "cannot remove %s", bak);
 
     free (bak);
 }

or those files should be named as "modules.bak".  

--alexm



reply via email to

[Prev in Thread] Current Thread [Next in Thread]