[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

ANNOUNCE: GIMP 2.2-pre1 (the Halloween Release)

From: Sven Neumann
Subject: ANNOUNCE: GIMP 2.2-pre1 (the Halloween Release)
Date: Tue, 02 Nov 2004 00:10:07 +0100
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/21.3.50 (gnu/linux)


we are glad to announce the availability of the first pre-release for
GIMP 2.2. More than half a year after GIMP 2.0 saw the light of day,
we are now close to finish work on it's successor, GIMP 2.2. You can
download a first pre-release from and it's mirrors:

This preview should have all the features that 2.2.0 will have.
However since this code hasn't seen a lot of testing yet there are
certainly bugs. If you find any, make sure you report them at (after checking that it isn't reported already).

The GIMP Wiki has a list of changes from GIMP 2.0 to GIMP 2.2:

Please do not install this pre-releae of GIMP 2.2 into the same prefix
as GIMP 2.0. It would overwrite most of the GIMP 2.0 installation. To
install in parallel to 2.0, please use a different prefix which is not
in your default library search path. If you wish to replace GIMP 2.0
with this pre-release, then please remove the GIMP 2.0 installation
before installing this software. For detailed installation
instructions, see the file INSTALL.

The GIMP 2.2 plug-in API is fully backward compatible to GIMP 2.0.
Plug-ins for GIMP 2.0 should continue to work and don't need to be
recompiled. We do however hope that plug-in authors will update their
plug-ins for GIMP 2.2 and adapt the GUI and API changes we did with
this version.

It might turn out that we have to do some late changes to the newly
added API before the final 2.2.0 release, so don't consider the API
strictly frozen yet. The API is however guaranteed to be backward
compatible (source and binary) with the GIMP 2.0 API. If you find that
your 2.0 plug-in breaks when used with the GIMP 2.2 libraries, or if
you cannot compile a GIMP 2.0 plug-in against the GIMP 2.2 header
files, please report that as a bug.

Overview of Changes since GIMP 2.1.7

- Added more plug-in previews (Displace, Color To Alpha, Newsprint)
  and ported existing previews to the new widgets (Glass Tiles).

- Added preview to WMF loader plug-in.

- Added Retinex plug-in for color normalization.

- Added plug-in to load and save raw image data (_not_ the raw format
  used by some digital cameras)

- Added a GUI to configure controller modules.

- Let lots of core dialogs remember their last values and add
  shortcuts to run with the last values w/o opening the dialog.

- Added new PDB API for drawable tranformations.

- Register all libgimp enums to allow language bindings such as
  Script-Fu to access them using GType introspection.

- Improved how we attach user-visible strings to enums registered with
  the type system. Added API to access these strings to libgimpbase.

- Cleanups to the new GFig GUI (still work in progress).

- HIGification of the ImageMap plug-in.

- Cleaned up dialogs code.

- Added Auto Whitebalance menu item.

- Redid Scale and Resize dialogs.

- Added code to migrate user settings from ~/.gimp-2.0.

- lots of bug fixes.


   Michael Natterer, Sven Neumann, David Odin, Manish Singh, Kevin Cozens,
   Joao S. O. Bueno, Geert Jordaens, Yeti, Karine Proot, Øyvind Kolås,
   Simon Budig


reply via email to

[Prev in Thread] Current Thread [Next in Thread]