[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

GNU CLISP 2.39 (2006-07-16)

From: Sam Steingold
Subject: GNU CLISP 2.39 (2006-07-16)
Date: Mon, 17 Jul 2006 13:29:15 -0400
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.0.50 (gnu/linux)

ANSI Common Lisp is a high-level, general-purpose programming language.
GNU CLISP is a Common Lisp implementation by Bruno Haible of Karlsruhe
University and Michael Stoll of Munich University, both in Germany.
It mostly supports the Lisp described in the ANSI Common Lisp standard.
It runs on most GNU and Unix systems (GNU/Linux, FreeBSD, NetBSD, OpenBSD,
Solaris, Tru64, HP-UX, BeOS, NeXTstep, IRIX, AIX and others) and on
other systems (Windows NT/2000/XP, Windows 95/98/ME) and needs only
4 MB of RAM.
It is Free Software and may be distributed under the terms of GNU GPL.
The user interface comes in English, German, French, Spanish, Dutch,
Russian and Danish, and can be changed at run time.
GNU CLISP includes an interpreter, a compiler, a debugger, CLOS, MOP,
a foreign language interface, sockets, i18n, fast bignums and more.
An X11 interface is available through CLX, Garnet, CLUE/CLIO.
GNU CLISP runs Maxima, ACL2 and many other Common Lisp packages.

More information at
  <> and
Sources and selected binaries are available by anonymous ftp from
and its mirrors.

2.39 (2006-07-16)

User visible changes

* SAVEINITMEM now accepts :SCRIPT argument that disables interpreting
  the first positional argument as the script name; and :DOCUMENTATION
  argument that is printed by the new -help-image command line option.
  See <> and
  <> for details.

* FFI:UINT64 and FFI:SINT64 are now compatible with C's long long type.

* Stack overflow detection and recovery finally work fine on Unix.
  Libsigsegv is required for this, on all platforms (including MS-Windows).
  CLISP should neither exit nor crash under infinite recursion.
  If your distribution has CLISP compiled without libsigsegv, report
  the missing feature to its maintainer.
  Note that libsigsegv 2.4 is required, there are bugs in libsigsegv 2.3!

* It is now possible to specify the default method-combination of a generic
  function, to be used when the DEFGENERIC form does not specify the
  :METHOD-COMBINATION explicitly, through a default initarg specification
  for the :METHOD-COMBINATION keyword on the generic function class.

* Readline completion works with non 1:1 terminal encodings, e.g. UTF-8.

* WITH-KEYBOARD works with a Unix tty even when SLIME hijacks *TERMINAL-IO*.

* I/O operations on Win32 are now much faster.


* Infrastructure:
  + Top-level configure now accepts a new option --with-gmalloc to use the
    GNU malloc implementation instead of the one supplied by libc.
    You may need it on older HP-UX and newer OpenBSD systems.
    See file unix/PLATFORMS for more information.
  + The value of the environment variable CFLAGS is respected by configure.

* Bug fixes:
  + SOCKET:SOCKET-SERVER :INTERFACE now behaves as documented.
    buffered binary sockets.
  + Allow DESTRUCTURING-BIND (a . b) with circular and dotted lists.
  + ADJUST-ARRAY of zero length adjustable string now works.
  + TIME now reports correct results when the heap grows over 4GB.
  + RAWSOCK functions now handle :START/:END arguments correctly.
  + POSIX:GROUP-INFO and POSIX:USER-INFO now handle errors correctly.

* Portability:
  + Support DragonFly BSD.

Sam Steingold ( on Fedora Core release 5 (Bordeaux)
Apathy Club meeting this Friday.  If you want to come, you're not invited.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]