info-gnus-english
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Gnus hang, when sending mail from gmail account with gnutls.


From: Richard Riley
Subject: Re: Gnus hang, when sending mail from gmail account with gnutls.
Date: Sun, 15 Aug 2010 14:11:27 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.0.50 (gnu/linux)

filebat Mark <address@hidden> writes:

> One more confusing:
> - Since I have explicitly configured to use gnutls by (setq 
> starttls-use-gnutls t), why we have STARTTLS output in the buffer of "*trace 
> of SMTP seesion".
>
> Regards,
> Denny
>
> On Sun, Aug 15, 2010 at 5:59 PM, filebat Mark <address@hidden> wrote:
>
>     Hi gnusers
>    
>     I can receive mails of gmail by imap. However, after struggling for 
> several days, I still fail to send mail in gnus.
>     Would you please help to root cause the problem? My environment: cygwin + 
> ntemacs 23.
>    
>     Below is my gnus related configuration, and ~/.authinfo is correct.
>    
>     And it hangs with the output of "220 2.0.0 Ready to start TLS", when I 
> try to invoke message-send in *Message* mode.
>     No problem is found, when manually invoke "gnutls-cli-debug.exe 
> www.google.com".
>    
>     It seems hang at smtpmail.el::smtpmail-via-smtp
>     line 672        (if (or (null (car (setq greeting
>     (smtpmail-read-response process))))

As a workaround ...

There was a thread earlier in the year about this. The same issue crops
up a lot (under Linux AND Windows btw) and TLS confuses a lot of people
and/or seems very creaky. - I know it did me ;) The thread earlier in
the year posted a solution using msmtp I *think* :--

http://www.mail-archive.com/address@hidden/msg08606.html

Hopefully this might work for you.

regards

r.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]