[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: PATCH: Support autoconf 2.50 in libtool.m4

From: Gary V . Vaughan
Subject: Re: PATCH: Support autoconf 2.50 in libtool.m4
Date: Mon, 25 Jun 2001 01:21:05 +0100

Hi again Paolo!

On Monday 18 June 2001  4:32 pm, Paolo Bonzini wrote:
> This patch is an autoupdated (and manualfixed...)
> version of libtool.m4 to work fine with autoconf 2.50.
> It passes autoconf -W obsolete.
> In particular, obsoleted macros have been updated
> and backquotes are not quoted anymore in AC_MSG_xxx.
> I have also used AC_MSG_NOTICE for the `creating
> libtool' message

Again, I don't want to apply this patch in the 1.4 branch, since it breaks 
compatibility with autoconf-2.13.  However, I am inclined to have 1.5 use 
autoconf 2.50 (or 2.51).  I would accept a similar patch against HEAD unless 
anyone here has a good reason not to take advantage of the improved features 
of the latest autoconf?

For example, the language stack works better, the trace facility makes 
debugging much easier, the AC_REQUIRE bug is fixed (there is a workaround in 
the toplevel but the demo configures are still affected), and we 
would be able to move generation of libtool itself into config.status.  Are 
there any counter arguments?

  ())_.  Gary V. Vaughan     gary@(|
  ( '/   Research Scientist        ,_())____
  / )=   GNU Hacker   \'      `&
`(_~)_   Tech' Author    =`---d__/

reply via email to

[Prev in Thread] Current Thread [Next in Thread]