libtool-patches
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Win32 impgen bug


From: Naofumi Yasufuku
Subject: Win32 impgen bug
Date: Fri, 23 Aug 2002 16:29:24 +0900
User-agent: Wanderlust/2.8.1 (Something) SEMI/1.14.3 (Ushinoya) FLIM/1.14.3 (Unebigoryōmae) APEL/10.3 Emacs/21.2 (i686-pc-linux-gnu) MULE/5.0 (SAKAKI)

impgen.exe cannot treat the symbol names includes '.' correctly.

This is a patch to fix it.

ChangeLog:
=====================================================================
2002-08-23  Naofumi Yasufuku  <address@hidden>

        * libtool.m4: impgen.c bug fix to treat the symbol names
        includes '.' correctly.

=====================================================================

Patch:
=====================================================================
diff -ur libtool.orig/libtool.m4 libtool/libtool.m4
--- libtool.orig/libtool.m4     Fri Sep 21 12:06:40 2001
+++ libtool/libtool.m4  Fri Aug 23 11:44:52 2002
@@ -5193,7 +5193,10 @@
 #     for (i = 0; i<nexp; i++)
 #     {
 #      unsigned long name_rva = pe_as32 (erva+name_rvas+i*4);
-#      printf ("\t%s @ %ld ;\n", erva+name_rva, 1+ i);
+#      if (strchr (erva+name_rva, '.') != NULL)
+#        printf ("\t\"%s\" @ %ld ;\n", erva+name_rva, 1+ i);
+#      else
+#        printf ("\t%s @ %ld ;\n", erva+name_rva, 1+ i);
 #     }
 #
 #     return 0;
=====================================================================

Regards,
--Naofumi




reply via email to

[Prev in Thread] Current Thread [Next in Thread]