[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [patch 05/19] 288-gary-ltdl-nonrecursive-tests.diff Queue

From: Ralf Wildenhues
Subject: Re: [patch 05/19] 288-gary-ltdl-nonrecursive-tests.diff Queue
Date: Tue, 11 Oct 2005 12:21:23 +0200
User-agent: Mutt/1.5.11

Hi Gary,

Just responding to some issues for now:

* Gary V. Vaughan wrote on Tue, Oct 11, 2005 at 11:53:17AM CEST:
> Ralf Wildenhues wrote:
> >* Gary V. Vaughan wrote on Mon, Oct 10, 2005 at 12:26:29PM CEST:
> >>    * tests/ New tests for libltdl as a subdirectory,
> >>    configured and compiled from the toplevel project.
> >>    * tests/ Use it.
> >>    * (TESTSUITE_AT): Depend on it.
> >
> >See nits below, and this one: all of them FAIL with 2.59/1.9.6 (without
> >libobjdir fixes):

> >>+# _LTDL_SETUP
> >
> >The naming is unfortunate.  As all the tests share an m4 macro name
> >space, and you actually use _LTDL_SETUP in several othere tests for a
> >different purpose, please rename all of them.
> No need, it's fine.  The name is quoted in the m4_define exactly so that
> we can do this sort of thing.  What is the point of renaming?
> >Maybe m4_undefine at the
> >end of the test would be ok as well, but then I believe you wanted to
> >share some macros.
> Okay.  That's less intrusive.  I'll pushdef/popdef the definition then,
> which is the cleanest way to stop it leaking out into other tests.

The pushdef/popdef is with me, thank you.

> >
> >Why do you need this?  Is it only for Automake backwards compatibility?
> subdir-objects requires it.
> >If so, then I recommend adding AC_PROG_CC before as well.
> Seems like overkill to me... Belt and braces?

Yes.  Quoting automake/ChangeLog:
| 2004-09-10  Alexandre Duret-Lutz  <address@hidden>
|         * m4/minuso.m4 (AM_PROG_CC_C_O): Make sure AC_PROG_CC is never
|         called after this macro.

My request is for user education.

> $ fgrep -l AM_PROG_CC_C_O /usr/share/aclocal*/*.m4

But thanks anyway for the history analysis.  :-)

> >>+AM_INIT_AUTOMAKE([foreign subdir-objects])
> >
> >I believe you should have AM_INIT_AUTOMAKE before AM_PROG_CC_C_O.
> >After all, AM_INIT_AUTOMAKE should be the first automake macro called.
> Again, I'm not sure about this reasoning :-)  AM_PROG_CC_C_O is designed
> to be a wrapper for AC_PROG_CC,

No, it's *documented* to be necessary in some cases.  The fact that it
AC_REQUIREs AC_PROG_CC is an *implementation detail*, the user _should_
use both.  Hey, persuade the Automake maintainer to document
"calling `AM_PROG_CC_C_O' makes previous calling of `AC_PROG_CC'
obsolete" and I will change my mind.

> and surely AC_PROG_CC should come before AM_INIT_AUTOMAKE?

Not at all, why?  INIT sounds like: do this first.  Right?
Sounds right to me.  Everything that has to become before this _needs_
to be documented very explicitly.  Quoting (Complete):

|    The first step is to update your `' to include the
| commands that `automake' needs.  The way to do this is to add an
| `AM_INIT_AUTOMAKE' call just after `AC_INIT':

This sounds very different to me.

> I don't want to change this, but if you are firm, and
> it still works then I can be persuaded...

Yes, I am (unless you persuade the Automake maintainer to change the
documentation).  For education purposes.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]