[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: libltdl exports no symbols (cygwin)

From: Eric Blake
Subject: Re: libltdl exports no symbols (cygwin)
Date: Tue, 30 Jan 2007 22:59:14 -0700
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20061207 Thunderbird/ Mnenhy/

Hash: SHA1

According to Charles Wilson on 1/30/2007 10:10 PM:

Hello everyone,

>> This whole issue seems not good for branch-1-5.  I'm pondering backing
>> out all related changes from branch-1-5; that is, the NEWS update and
>> the LT_GLOBAL_DATA/LT_SCOPE change of 2007-01-28, as well as the
>> DLL_EXPORT change of 2006-06-01.  We cannot do such a big change for
>> 1.5.24, that will affect all users of --with-included-ltdl. 

The problem is not with 1.5.24.  CVS M4 _already_ relies on CVS libtool,
and the only way that I have been developing M4 head on cygwin is by first
installing my own CVS snapshot of libtool, rather than using the cygwin
version.  Rather, the breakage comes because we forward ported a 1.5 patch
to head, and I'm not sure whether the breakage is in libtool, or broken
usage by m4, or a combination thereof.

> [*] BTW, I have a longer email I was putting together concerning the
> root cause of M4's problems w.r.t. LT_SCOPE, DLL_EXPORT, and friends. To
> wit: CVS M4 has been borked on cygwin for YEARS. Breakage now is nothing
> new...and reverting cygwin libtool to its broken state vis-a-vis gettext
> simply to help CVS M4 -- which is borked anyway -- is nonsensical.

I'm inclined to agree - CVS M4 needs help anyway.  My observation was more
along the lines of the current situation is broken whereas it wasn't last
week, so what can I do to help pull things into better shape?

> ---
> Do what you want, but I am strongly inclined to continue future official
> cygwin releases of libtool RETAINING the 2006-06-01 and 2007-01-28
> changes. I do not look favorably on releasing yet ANOTHER
> backwards-incompatible version of libtool/libltdl on the cygwin
> platform, while pretending that it is still compatible.

I would argue that libtool should maintain the patch, as I trust Charles'
builds on cygwin and don't want to see him forking from the upstream
tarball if it can be helped - no need to revert it, as the breakage has
not been seen on released software, but only on CVS m4 which is already
bleeding edge dependent, and can afford to make adjustments to accomodate
this latest change.

> BTW -- it's obvious to me that the reason Eric never noticed this
> problem until Ralf committed the change to libtool CVS HEAD, was because
> he has NOT actually been using cygwin official released (e.g.
> libtool-1.5.23a) libtool.  He's been using libtool CVS HEAD to develop
> CVS M4.  So don't use CVS M4 breakage observed with libtool CVS HEAD as
> a justification for re-breaking cygwin libtool 1.5.24.

Correct.  And if nothing else, CVS m4 proves to be a fun playground for
what libtool should be able to do, even on braindead platforms like Windows.

- --
Don't work too hard, make some time for fun as well!

Eric Blake             address@hidden
Version: GnuPG v1.4.5 (Cygwin)
Comment: Public key at
Comment: Using GnuPG with Mozilla -


reply via email to

[Prev in Thread] Current Thread [Next in Thread]