[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 1/6] Require Automake 1.11.1 for Libtool, enable color-tests.

From: Ralf Wildenhues
Subject: Re: [PATCH 1/6] Require Automake 1.11.1 for Libtool, enable color-tests.
Date: Sun, 22 Aug 2010 17:30:13 +0200
User-agent: Mutt/1.5.20 (2010-04-22)

* Gary V. Vaughan wrote on Sun, Aug 22, 2010 at 05:24:05PM CEST:
> On 22 Aug 2010, at 22:09, Ralf Wildenhues wrote:

> > # consider using shallow clones here, to ease server load.
> > git clone git://
> > git clone git://
> We could pull the already bootstrapped release tarballs from an
> mirror here instead.


> > git clone git://
> Of course, that doesn't test the patch series you haven't
> pushed yet...

Just add 'git checkout origin/parallel-tests'.

> And running it as an Autotest inside the existing tree would
> get us better coverage, and obviate the need for a separate
> checkout of the libtool tree entirely.

Sure.  But look at the existing sort-of-recursive tests.  They are
tricky.  I am waiting for the day where we add infinite recursion in
some corner case and have developers complain.

The net is abundant now, I think such test helper scripts are a real
easy way to get more coverage, but I don't think it is necessary to
run them as part of each testsuite run, because they are very expensive.

> > # Now, mail all output and logs to the autobuild site ...
> > # ... and consider cleaning up afterwards.
> The last bit of the script is missing ;)

TBD when I have all the autobuild setup figured out and all.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]