[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: How is relinking with DESTDIR != installdir in newish libtool?

From: R.I.P. Deaddog
Subject: Re: How is relinking with DESTDIR != installdir in newish libtool?
Date: Sat, 15 Feb 2003 10:00:10 +0800

On 2003-02-14(Fri) 17:19:29 -0600, Tim Mooney wrote:
> In regard to: How is relinking with DESTDIR != installdir in newish...:
> >Has this problem been solved in the newer libtool such as 1.4.3 or 1.5?
> >  How?  I just looked at from 1.4.3 and there is no DESTDIR.
> 1.4.3 solved it in a different way, using a patch based either
> partially or fully on work done by Ossama Othman (I think).  It adds an
> argument "-inst-prefix-dir" that gets passed to libtool during the relink
> that happens during install.  It all happens automatically, so there's
> nothing new that a package builder needs to worry about.

I observed something different, but got no answer from this list, so
I'll try it again: the -inst-prefix-dir option doesn't place the
-L$DESTDIR/libdir as the first -L flag forcefully, and it is still
possible to include system library paths before it.

That means, software will always build without the aforementioned error
(relinking fail because no library was found), but introduced another
risk: programs/libraries will link with old version of libraries found
in system lib paths, instead of libraries inside $DESTDIR.

I observed this when compiling ImageMagick; do I need to provide more
detail on how I reproduce it (such as compile log files)?


> 1.4.3 has been working relatively well for me, for the majority of
> packages I've built with it.  I use BuildRoot installs exclusively.
> Tim
Abel Cheung
GPG Key: (0xC67186FF)

Attachment: pgpBhtuv1KqNc.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]