[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: CygWin woes

From: Robert Boehne
Subject: Re: CygWin woes
Date: Fri, 18 Apr 2003 17:49:08 -0500


Where are the undefined symbols?  If they are in your own code, perhaps
defined in the executable, then you won't be able to port to Win32,
Under Windows, DLL's have to be fully resolved, this is always a good
but Windows is the only platform that I'm aware of where it is required.
If your project is building and running under Linux (or some similar OS)
you can add a linker flag to cause it to be an error if a symbol is
That may help you find out where the problem is.



Magnus Therning wrote:
> Hi,
> My first posting to the list :-)
> This might very well be a question that has popped up before, I have
> googled around but haven't found any solution to it, so pointers are
> more than welcome.
> The problem:
> I don't manage to build DLLs undet CygWin. Libtool gives a warning that
> undefined symbols aren't allowed in DLLs on the i686-cygwin platform. No
> report on what symbols are undefined.
> I am using libtool together with automake. The standard CygWin
> distribution of libtools, so that means version 1.4e.
> Any help is appreciated.
> /M
> --
> Magnus Therning  mailto:address@hidden  PGP:0xD3BC7468
> +31-40-2745179
> In any business model you need someone to sue. That's the American way.
>      -- Bill Weinberg, MontaVista
>   ------------------------------------------------------------------------
>    Part 1.1.2Type: application/pgp-signature
>   ------------------------------------------------------------------------
> _______________________________________________
> Libtool mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]