[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

DESTDIR trouble

From: Bernd Jendrissek
Subject: DESTDIR trouble
Date: Fri, 4 Jul 2003 11:52:57 +0200

I realise this may be an FAQ candidate, but I haven't gotten any joy out
of google or the archives.

My problem:

I have, say, guile 1.4 installed, with in /usr/lib.  Now
I've tried to build guile 1.6.4 with a DESTDIR=foo install, but then
things get linked with the guile libs *in /usr/lib*!  (I think most of
you should be familiar with the scenario.)  So I have new libraries linked
to the old ones.

I have libtool 1.5 installed, and it *doesn't* work properly with DESTDIR.
I've seen DESTDIR-related messages in the archives, but they always seem
to wind down with "this is fixed in 1.5" or something to that effect.

A while back I tried looking at and after much hair-pulling I
found a spot where $deplibs get reordered.  WHY???  Is it accidental, or
is there some purpose?  The problem is that even though -L/usr/lib gets
put at the *end* $deplibs, a subsequent loop reverses everything!

(Unfortunately I've lost the place, and any change is likely to be
non-trivial, and my employer talks about "internal open-source", so I'm
unlikely to be able to contribute any patches.)

I'd prefer a proper fix, not some LIBRARY_PATH=foo hackery.  Any

-- - at last it even exists!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]