[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[support #102347] AIX whole_archive_... revisited

From: nobody
Subject: [support #102347] AIX whole_archive_... revisited
Date: Mon, 11 Aug 2003 18:58:57 -0400
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030718

Support Request #102347, was updated on Mon 08/11/2003 at 22:58
You can respond by visiting:

Category: None
Status: Open
Priority: 5
Summary: AIX whole_archive_... revisited

By: thomason
Date: Mon 08/11/2003 at 22:58
Logged In: YES 
Browser: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030718

Since CVS revision 1.294 my convenience library on AIX
has broken.  This seems to be because that patch
removes $convenience from $deplibs, but AIX (at least
with my configuration) has $whole_archive_flag_spec='
'.  This problem was anticipated by chrisp in reply to
support #100049 on Sun 09/09/2001.  There was a
discussion on the libtool list in May '01 regarding the
empty $whole_archive_flag_spec, but apparently there
was never a resolution (libtool.m4 in today's cvs still
contains _LT_AC_TAGVAR(whole_archive_flag_spec, $1)=' '
at line 2859).

Is this a bug introduced by the 1.294 patch or is there
a way around it for AIX?

-Adam Thomason

P.S. This aside, libtool has made my life much easier;
thanks to all the developers for their efforts.

You can respond by visiting:

  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]