[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Unhelpful behaviour on Cygwin when "file" isn't installed

From: Ralf Wildenhues
Subject: Re: Unhelpful behaviour on Cygwin when "file" isn't installed
Date: Tue, 14 Feb 2006 23:40:43 +0100
User-agent: Mutt/1.5.9i

Hi Olly,

* Olly Betts wrote on Tue, Feb 14, 2006 at 08:06:52PM CET:
> I tried to search for previous references to this issue, but it's pretty much
> impossible to usefully search for "file"!  Sorry if this is rehashing old
> discussions.

It's not really, but there is a very similar bug report and patch
outstanding (which I temporarily forgot about):

Probably the issue can be solved to not use `file' at all, but I'd still
need to think about that.

> A user reported a problem trying to build my libtool-ed project on cygwin.
> The problem turned out to be that cygwin apparently doesn't install the
> "file" utility by default, but libtool tries to use it without checking
> if it is available (in func_win32_libid it seems).  I'm using libtool 1.5.22.
> Here's the output in question:

> If "file" isn't available on cygwin by default, I feel it would be better to
> say so rather than to say that a (probably valid) library failed the file 
> magic
> test...


> Also, I have AC_DISABLE_STATIC in, so I'm slightly suprised that
> libtool falls back to building a static library here.  Is that supposed to
> happen?

Yes, I think that is by design: if libtool doesn't know how to build a
shared lib, it should fall back to what it knows instead.  At least that
seems to me one common reasoning in some libtool constructs.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]