[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Unhelpful behaviour on Cygwin when "file" isn't installed

From: Olly Betts
Subject: Re: Unhelpful behaviour on Cygwin when "file" isn't installed
Date: Fri, 17 Feb 2006 18:55:58 +0000
User-agent: Mutt/1.3.28i

On Tue, Feb 14, 2006 at 08:12:58PM -0600, Bob Friesenhahn wrote:
> On Tue, 14 Feb 2006, Ralf Wildenhues wrote:
> >* Olly Betts wrote on Tue, Feb 14, 2006 at 08:06:52PM CET:
> >>I tried to search for previous references to this issue, but it's pretty 
> >>much impossible to usefully search for "file"!  Sorry if this is
> >>rehashing old discussions.
> >
> >It's not really, but there is a very similar bug report and patch
> >outstanding (which I temporarily forgot about):
> >

The message (and problem) are similar, but that's about cross-compiling
to mingw rather than native building on cygwin it seems.  But a similar
patch would probably work for cygwin I guess.

> >Probably the issue can be solved to not use `file' at all, but I'd still
> >need to think about that.
> At one time Cygwin used 'objdump' rather than 'file'.  Later it was 
> improved to use 'file' since file returns more accurate results.  For 
> MSYS/MinGW 'objdump' is still used because 'file' does not come with 

The user who reported this to me says that cygwin doesn't come with
file by default either (he'd installed it very recently, so I guess
he probably has the latest release).  I'm a little suprised by this,
but don't have cygwin myself so I can't check if this really is the


reply via email to

[Prev in Thread] Current Thread [Next in Thread]