[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: error message upgrading to newest libtool...

From: Ed Hartnett
Subject: Re: error message upgrading to newest libtool...
Date: Fri, 24 Feb 2006 11:05:21 -0700
User-agent: Gnus/5.1006 (Gnus v5.10.6) Emacs/21.4 (gnu/linux)

"Gary V. Vaughan" <address@hidden> writes:

> Ed Hartnett wrote:
>> Howdy all!
>> I got the latest libtool from the CVS and installed it. Now when I
>> build my library, I get the following error:
>> libtool: Version mismatch error.  This is libtool 2.1a, but the
>> libtool: definition of this LT_INIT comes from an older release.
>> libtool: You should recreate aclocal.m4 with macros from libtool 2.1a
>> libtool: and run autoconf again.
>> make[1]: *** [fort-attio.lo] Error 1
>> make[1]: Leaving directory `/shecky/n3_new/fortran'
>> make: *** [check-recursive] Error 1
>> I have tried rm aclocal.m4, and autoreconf --force.
>> But nothing has worked. Any suggestions?
> This is telling you that your project is picking up an old libtool.m4,
> and the latest  Have you installed your new libtool to a
> different prefix from the old one?  Where is your aclocal command
> collecting macros from?

Yes, this is the exact case!

I had installed a new libtool, also changed my path, and also
installed it in a different directory. To add to the confusion there
are older versions of various tools in various directories on this
machine, and some of them were getting into the act too.

This caused enough confusion to create this error.

In the end, I reinstalled autoconf (in the same directory as libtool,
but I don't think that was the issue anyway), did an autoreconf and an
aclocal, and then everything worked perfectly.

"...The libtool menace was at an end. The quest for the holy grail
could continue!"



Ed Hartnett  -- address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]