[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Seemingly Basic Problem

From: Lee Reis
Subject: Re: Seemingly Basic Problem
Date: Tue, 27 Jun 2006 21:43:56 -0400

I'm not sure where those two pieces fit into what I'm doing. Maybe compile isn't the right word, I'm using "make" and that's when the error appears. Should I be putting libtool and some other commands with those two lines?

Thanks for the help,


On Jun 27, 2006, at 3:39 AM, Francesco Calimeri wrote:

try adding


just before "-lltdl" in your command line (order is important).


I'm trying to compile a program with Mac OS X Darwin, but eventually
this happens:

/bin/sh ../libtool --tag=CXX --mode=link g++     -o player -export-
dynamic server.o -lm ../server/libplayerdrivers/ ../libplayercore/ ../
libplayercore/ ../libplayertcp/ ../
libplayerxdr/                           -L/usr/local/
lib -lcxcore -lcv -lhighgui -lcvaux                      -L/sw/lib -
lgdk_pixbuf-2.0 -lm -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -lintl -
liconv                   -L/usr/local/lib -lcxcore -lcv -lhighgui -
lcvaux      -L/usr/local/lib -lcxcore -lcv -lhighgui -lcvaux      -L/
usr/local/lib -lcxcore -lcv -lhighgui -lcvaux
../replace/ -lpthread -lcrypto  -lz -lltdl -ldl
libtool: link: cannot find the library `/usr/lib/gcc/powerpc-apple-
make[3]: *** [player] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

I've searched, and I know that is in the directory /sw/
lib.  How do I set the configuration so that it changes the directory
that it looks for in?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]