[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cannot a directory not ending in

From: Ralf Wildenhues
Subject: Re: cannot a directory not ending in
Date: Fri, 22 Sep 2006 16:36:05 +0200
User-agent: Mutt/1.5.13 (2006-09-01)

Hello Jeff,

* Jeff Blaine wrote on Fri, Sep 22, 2006 at 04:17:07PM CEST:
> Okay, I've run into this enough that it's taken its toll
> on me and I must know the proper modern way to handle this.

Hmm.  This sounds like it used to work before and we broke something.
Is it what you are implying?

> For years and years, the following worked fine for any
> GNU app using autoconf:
>      ./configure --prefix=/my/final/destination
>      make
>      make install prefix=/my/to-be-released/destination

Not with Libtool-using packages, at least not bug-free, as far as I

  make install DESTDIR=/my/staging/directory

works to install your stuff temporarily into

from where it can be moved to

and, after a 
  libtool --mode=finish /my/final/destination/lib

libraries should be useable.

There are issues in current libtool that prevent this from working
properly in _some_ cases when you try to link against third-party
libraries that currently are visible below

but are to finally appear at

See some other discussion on this list just this week.

> It has often not worked when involving libtool over the
> last year or two and it's driving me nuts.  Can someone
> PUHLEEEEZE tell me the right way to do this?

Well, I'm really sorry you've had so much trouble, and I can only ask to
report issues earlier.  If you think there is a regression involved then
please point me to a package where this should have worked.

Hope that helps.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]