[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 2.4 Release in 24hrs

From: Ralf Wildenhues
Subject: Re: 2.4 Release in 24hrs
Date: Mon, 20 Sep 2010 19:41:05 +0200
User-agent: Mutt/1.5.20 (2010-08-04)

* Charles Wilson wrote on Mon, Sep 20, 2010 at 01:39:38AM CEST:
> On 9/19/2010 12:57 PM, Charles Wilson wrote:
> > On 9/19/2010 11:45 AM, Bob Friesenhahn wrote:
> >> Unfortunately, my MinGW testing is not so successful.  The testing still
> >> quits part-way through with some sort of make-related issue (as reported
> >> in detail previously).
> > 
> > Odd.  My last test on MinGW was very successful. This was version 1.3266
> > (ef56e98f3 IIRC).  I'll give it another go @ f0584085.
> old -- All 122 tests passed (2 tests were not run)
> new -- 108 tests behaved as expected.  12 tests were skipped.

I'd really appreciate if you guys could send build logs to the autobuild
server as I've been doing lately, much more than just posting
non-verbose results on the list here.

You don't need to have autobuild installed.  When Eric installs
autobuild.m4 you don't need to do anything else.

Here's what I use, more or less, to create the logs:

  ( ../libtool/configure [OPTIONS] \
    && make \
    && make -k check
    cat test-suite.log tests/testsuite.log
    if tail tests/testsuite.log | grep '^| ' >/dev/null; then :; else
      sed 's/^/| /' config.log
  ) > logfile

  $sanitize logfile
  mail < logfile

with the underscore replaced by @.  For now, OPTIONS includes
autobuild_mode=bla if there is anything special about the build.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]