[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Version mismatch error

From: Ralf Wildenhues
Subject: Re: Version mismatch error
Date: Wed, 20 Oct 2010 19:49:15 +0200
User-agent: Mutt/1.5.20 (2010-08-04)

Hello Sergio,

* Sergio Belkin wrote on Mon, Oct 18, 2010 at 06:33:17PM CEST:
> I have project with autotools made on Ubuntu, but when I want to
> compile on CentOS it ends with error:
> libtool: Version mismatch error.  This is libtool 2.2.6b
> Debian-2.2.6b-2ubuntu1, but the
> libtool: definition of this LT_INIT comes from libtool 2.2.10.
> libtool: You should recreate aclocal.m4 with macros from libtool
> 2.2.6b Debian-2.2.6b-2ubuntu1
> libtool: and run autoconf again.
> I was using   2.2.10 (compiled) on CentOS. Is there not compatibility
> between 2.2.x releases. Is there not a way to make it works with any
> libtool 2.2.x?

The 2.2.x releases are all compatible in the sense that the command-line
API between them is upward-compatible.  However, the version from which
the libtool.m4 and ltversion.m4 (and a couple more files) macros are
taken, and the file is from, must be exactly identical.  The
API between ltmain and the macros is mostly an internal detail and not
guaranteed to remain stable between releases.  So if you re-libtoolize,
copying in a new, you need to also ensure that the new macros
are used.

Depending on your package setup, that means either passing --install to
libtoolize (when AC_CONFIG_MACRO_DIR has been set in, or
running aclocal with flags set so that it finds the right Libtool macros
(either by some -I include-path, or setting the path in the dirlist file
of the aclocal installation), or possibly hand-copying macro files or
file contents to your aclocal.m4 file.  Details are documented in the

Hope that helps.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]