[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Lilypond 2.0.1 built ok for FreeBSD 4.0 w/gcc 2.95.2

From: Jan Nieuwenhuizen
Subject: Re: Lilypond 2.0.1 built ok for FreeBSD 4.0 w/gcc 2.95.2
Date: Tue, 18 Nov 2003 09:34:23 +0100
User-agent: Gnus/5.1003 (Gnus v5.10.3) Emacs/21.3 (gnu/linux)

"R. D. Davis" <address@hidden> writes:

> Thanks for the reply.

Yes, but please keep this on the list.

> Alas, switching to g++ 3.x doesn't appear to be a possibility

This may not be very important, but see other post to list.

> That's what I thought. :-)

You may want to see/post what check went astray there.

> That's what I'm looking into now... If I run "midi2ly --help," I get
> the following error:
> Traceback (most recent call last):
>   File "/usr/local/bin/midi2ly", line 43, in ?
>     import midi
> ImportError: /usr/lib/ Undefined symbol "__ti9exception"

This is quite strange.  It looks like a gcc installation problem.
Firstly, the midi module should be compiled with gcc, not g++.
Secondly, libstc++3 is part of gcc-3.0, while you think you're using 2.95.

> If that will work as a last resort, I'll give it a try.  I'm hoping that
> if I can fix the aforementioned problem with midi2ly and then get the
> fonts working, all will be ok.
> Any thoughts on this?

Yes, I hope so.


Jan Nieuwenhuizen <address@hidden> | GNU LilyPond - The music typesetter       |

reply via email to

[Prev in Thread] Current Thread [Next in Thread]