[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: devel on OSX

From: Graham Percival
Subject: Re: devel on OSX
Date: Tue, 27 Jul 2004 14:37:47 -0700

On 27-Jul-04, at 2:07 PM, Matthias Neeracher wrote:
guile is in fink (actually, you need guile16).

I realize that, but it's configured in a weird way.  Or something.

Yes, it is. The part that I omitted in my e-mail was "look at the compile and install scripts in the lilypond fink package and adapt them to you needs". The key here is how I call configure:

BISON=/usr/bin/bison PYTHON=%p/bin/python2.2 GUILE=%p/bin/guile-1.6 GUILE_CONFIG=guile-1.6-config ./configure %c

Ah!  That works, thanks.

the two guile related environment variables set up for proper use of guile 1.6 (the python and bison variables may be less essential, the python one is just to ensure a consistent build and the latter to avoid unfortunate interactions with the fink bison package).

I'm a bit confused, though. In debian, I do "apt-get install guile-1.6-dev" (or something like that), and then I can compile stuff that needs guile-config. In fink, I need to export a GUILE_CONFIG variable? Is that something inherent in Apple's BSD layer, or just a quirk of fink's guile package?

Unfortunately, mftrace & co. are not yet available on MacOS X. The current fink packages "cheat" on the source builds by extracting the prebuilt fonts from the RedHat rpms. This may not be a viable strategy for CVS tracking.

mftrace will compile; I just tried it.

Interesting. Last time I tried to make a package, there were just too many unresolved dependencies, but somebody ported autotrace since then, so maybe I should make another attempt at packaging mftrace.

Once I had all the dependancies (including a few that ./configure and make didn't check for, such as t1utils) it seems to work fine. I could "mftrace cmr10" without any error messages.

Please let me know if other build issues crop up

After satisfying all the ./configure issues, I began "make all". Shortly after that, I got this:

g++ -shared -o out/ out/midi.lo -L/sw/lib -L/sw/lib -lguile -lguile-ltdl -lm
g++: unrecognized option `-shared'
ld: Undefined symbols:
make[1]: *** [out/] Error 1
make: *** [all] Error 2

spark-daemonology-net:~/usr/src/lilypond-2.3.8 gperciva$ g++ --version
g++ (GCC) 3.3 20030304 (Apple Computer, Inc. build 1495)
Copyright (C) 2002 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Why on earth would Apple's version of g++ not support the "-shared" option? (not that I have any idea what it does, but still...)

- Graham

reply via email to

[Prev in Thread] Current Thread [Next in Thread]