[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: make web fails for LilyPond 2.8.0/2.9.0 source drop [Also] Re: Futil

From: Han-Wen Nienhuys
Subject: Re: make web fails for LilyPond 2.8.0/2.9.0 source drop [Also] Re: Futile attempts to build LilyPond 2.8.0
Date: Tue, 04 Apr 2006 12:02:23 +0200
User-agent: Thunderbird 1.5 (X11/20060313)

Herman Grootaers wrote:
On Tuesday 04 April 2006 10:47, Andreas Scherer wrote:
R. Mattes <rm <at>> writes:
Ok, i found the "bug". It looks like this is triggered
by using guile-1.6.n instead of guile-1.8 - this also
explains why Andreas' build failed.
Confirmed. After updating OpenSUSE 10.0 with guile-1.8.0, all is well
again. "make all web" runs to completion with both the LilyPond 2.8.1
source drop and the 2.9.1 CVS contents.

I encountered the same error, But it is not a bug in itself; just that the configure tests against old versions of certain programs, guile and mftrace that i know about.

Maybe an action for the main-core developers to update the files which contain old info, so an end-user who is familiar with the normal build-procedure can use it.

the goal for 2.8 is to be compatible with guile 1.6 , and it largely is.

For 2.9/3.0 we will require guile 1.8, as we'll likely drop our in-house rational number support for GUILE's.


Han-Wen Nienhuys - address@hidden -

LilyPond Software Design
 -- Code for Music Notation

reply via email to

[Prev in Thread] Current Thread [Next in Thread]