[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lilypond on FreeBSD?

From: Ian Stirling
Subject: Re: lilypond on FreeBSD?
Date: Sun, 22 Oct 2006 17:19:51 -0400
User-agent: KMail/1.9.1

On Saturday 21 October 2006 03:55, you wrote:
> Ian Stirling <address@hidden> writes:
> >   I haven't managed to make Lilypond work on my
> > FreeBSD 6.1 system.  The precompiled version gives
> > a runtime error looking for a non existent library.
> What library is that?

/usr/libexec/ Shared object "" not found, required by 
/usr/libexec/ Shared object "" not found, required by 

 By using quick and dirty symbolic links pointing to the
current libraries, and, the FreeBSD
Lilypond 2.9.26 build from the site works, at least as far
as issuing the help message when invoked with no arguments.

> We base the FreeBSD binaries on 4.10-RELEASE-p2.  Would it make
> sense to support 6.x as well?  If so, we need a binary of
> the c library to bootstrap the build

  I'd certainly like you to support FreeBSD 6.x.
The version of Lilypond in the FreeBSD ports is the ancient 2.2.2.

>       tar -C / --exclude=zlib.h --exclude=zconf.h --exclude=gmp.h -czf 
> public_html/freebsd-runtime-$(uname -r).tar.gz 
> /usr/lib/{lib{c,c_r,m}{.a,.so{,.*}},crt{i,n,1}.o} /usr/include

  I have added /lib through that filter to the tar file because* and* are there.  I'll send you a private email
with a link to the file on a private page on my web site.

> >   No answers from anyone so far about where to find that
> > VeraBd.pfd. Am I reaching the list?
> Yes.  I do not have that file either.  It is not required to build
> LilyPond.  I do have a ttf version, however

I get the following error installing 2.9.22 and 2.9.24.

Cannot open /usr/X11R6/lib/X11/fonts/bitstream-vera/VeraBd.pfb
The requested file, VeraBd.pfb, does not exist
Open: Failed to open: /usr/X11R6/lib/X11/fonts/bitstream-vera/VeraBd.pfb
Called from...
 ../buildscripts/pfx2ttf.fontforge: line 3
gmake[1]: *** [out/CenturySchL-Ital.otf] Error 1

Compiling 2.9.26 fails with the following..

cc1plus: warnings being treated as errors In member function 'void Polynomial::check_sol(Real) const': warning: empty body in an if-statement
gmake[1]: *** [out/polynomial.o] Error 1
gmake[1]: Leaving directory `/usr/home/ians/.build/lilypond-2.9.26/flower'
gmake: *** [all] Error 2


reply via email to

[Prev in Thread] Current Thread [Next in Thread]