lilypond-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: reminder: input/lsr/* generated automagically


From: Graham Percival
Subject: Re: reminder: input/lsr/* generated automagically
Date: Mon, 16 Apr 2007 21:26:58 -0700
User-agent: Thunderbird 1.5.0.10 (Macintosh/20070221)

Han-Wen Nienhuys wrote:
some comments

+def copyWithWarning(src, dest):

Thanks, I've made these changes.

+       readFile = open(src, 'r')

'r' : superfluous

+       readFile.close()

superfluous. Happens automatically if it goes out of scope.

I was wondering about this, though: even if they're superfluous, aren't they good style? Having the 'r' and .close() there makes the code easier to read, especially if somebody isn't familiar with python.

Cheers,
- Graham




reply via email to

[Prev in Thread] Current Thread [Next in Thread]