[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 2.12 on Leopard

From: Josh Parmenter
Subject: Re: 2.12 on Leopard
Date: Sun, 28 Dec 2008 15:31:16 -0800

And: Python 2.5 is in this (it was part of LilyPad).

I'll try changing that John to see if I can get the bundle to work.


On Dec 28, 2008, at 3:28 PM, John Mandereau wrote:

Le dimanche 28 décembre 2008 à 17:02 -0600, Neil Tiffin a écrit :
This version referenced here, seemed to mostly work.  Except as
follows when trying to convert the initial template from 2.8 to
current (2.12.0).

ImportError: No module named shutil

Is there anything I can do to help get this fully working on Leopard?

What does "python --version" says?  IIRC Leopard comes with some 2.4.x
version, which includes shutil normally. If you really have Python 2.4 installed, please report the bug against Apple about the missing shutil
module and/or install a working Python version from
then edit


so the first line refers to the correct Python binary.

In case you install Python 2.6(.1) or 3.0, please report us even if you succeed, as LilyPond scripts have not been much tested with these Python


/* Joshua D. Parmenter

“Every composer – at all times and in all cases – gives his own interpretation of how modern society is structured: whether actively or passively, consciously or unconsciously, he makes choices in this regard. He may be conservative or he may subject himself to continual renewal; or he may strive for a revolutionary, historical or social palingenesis." - Luigi Nono

reply via email to

[Prev in Thread] Current Thread [Next in Thread]