[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GUB: reducing errors/warnings

From: Graham Percival
Subject: Re: GUB: reducing errors/warnings
Date: Thu, 25 Jun 2009 16:43:48 -0700
User-agent: Mutt/1.5.18 (2008-05-17)

On Thu, Jun 25, 2009 at 08:33:33AM +0200, Jan Nieuwenhuizen wrote:
> Op donderdag 25-06-2009 om 00:33 uur [tijdzone -0300], schreef Han-Wen
> Nienhuys:
> > Unfortunately, a lot of packages are not meant to be cross-compiled,
> > so a lot of things that GUB does are hackish.  I'd not worry too much
> > about the messages; as long as things work, there are things much more
> > important than polishing gub
> Combine that with laziness and ignorance and you have the reason why 
> our previous incarnations of cross build systems mostly worked with an
> old style [shellish/perlish] concept: ignore any errors unless
> explicitly checked and let's hope for the best--just as long as the
> **** thing builds!

I'm still not convinced that messages like
No such file or directory
are worth keeping; surely the dir in the relevant python file just
didn't get updated when the overall dir structure in GUB changed.

Anyway, you're right that it's not a priority at the moment, but
after 2.14 I'm going to spend more time looking at this.  And I
must admit that the GUB part seems to be working fine at the
moment; I have:
address@hidden:~/gub$ ls uploads/
lilypond-2.13.0-0.test-output.tar.bz2    lilypond-2.13.2-0.mingw.exe
lilypond-2.13.2-0.darwin-ppc.tar.bz2     lilypond-2.13.2-0.test-output.tar.bz2
lilypond-2.13.2-0.darwin-x86.tar.bz2     lilypond-2.13.2-HEAD.webdoc.tar.bz2
lilypond-2.13.2-0.documentation.tar.bz2  lilypond-2.13.2.tar.gz          localdoc         signatures            webdoc           webtest
address@hidden:~/gub$ ls uploads/webtest/

The problem now is still the bloody upload thing.  I have a 195K
log of the attempt; there's oodles of
rsync: failed to set times on "/var/www/lilypond/doc/v2.13/.":
Operation not permitted (1)
messages, followed by
rsync: failed to set times on
"/var/www/lilypond/doc/v2.13/input/tutorial": Operation not
permitted (1)

Number of files: 9762
Number of files transferred: 0
Total file size: 250095232 bytes
Total transferred file size: 0 bytes
Literal data: 0 bytes
Matched data: 0 bytes
File list size: 252289
File list generation time: 0.196 seconds
File list transfer time: 0.000 seconds
Total bytes sent: 256742
Total bytes received: 4423

sent 256742 bytes  received 4423 bytes  104466.00 bytes/sec
total size is 250095232  speedup is 957.61
rsync error: some files could not be transferred (code 23) at
main.c(1058) [sender=3.0.3]
chmod -R g+w .
chgrp -R lilypond .
chmod 2775 `find -type d ` .
rsync --exclude "*.signature" --hard-links --delay-updates
--delete --delete-after --stats --progress -pgorltvu -e ssh .
Traceback (most recent call last):
  File "/home/lilypond/gub/test-lily/", line 226,
in <module>
    main ()
  File "/home/lilypond/gub/test-lily/", line 222,
in main
    upload (opts, a)
  File "/home/lilypond/gub/test-lily/", line 202,
in upload
    system ('rsync --exclude "*.signature" --hard-links
--delay-updates --delete --delete-after --stats --progress
-pgorltvu -e ssh . %s/%s/' % (options.destination, branch_dir))
  File "/home/lilypond/gub/test-lily/", line 91,
in system
    raise Exception ('fail')
Exception: fail
test result does not exist for
test result does not exist for
test result does not exist for
test result does not exist for
test result does not exist for
test result does not exist for
test result does not exist for
test result does not exist for lilypond-2.13.2-0.mingw.exe
chgrp -R lilypond uploads/lilypond*
chmod -R g+rw uploads/lilypond*
python /home/lilypond/gub/test-lily/ \
  --upload address@hidden:/var/www/lilypond/doc \
Traceback (most recent call last):
  File "test-lily/", line 272, in <module>
    main ()
  File "test-lily/", line 265, in main
    system (cmd)
  File "test-lily/", line 78, in system
    raise Exception ('barf')
Exception: barf

I'm happy to send you the complete log if that would help.  Or if
a newer rsync would fix it, I'll install it manually in the user

- Graham

reply via email to

[Prev in Thread] Current Thread [Next in Thread]