[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with 2.13.30?

From: Reinhold Kainhofer
Subject: Re: Problem with 2.13.30?
Date: Mon, 30 Aug 2010 01:48:46 +0200

Am Montag, 30. August 2010, um 00:25:47 schrieben Sie:
> > I don't really see any other way to turn the input path to an
> > absolute path
> > than calling os.path.abspath, in particular, since the input path
> > can already
> > be an absolute path...
> But doesn't this solution create a worse problem
> than the original one?  With this fix lilypondbook
> cannot be used *at all* under Windows.  The original
> problem has a simple workaround which could be documented
> easily - the problem created by the fix has no
> workaround.

Yes, I see the problem...
On the other hand, without this fix, lilypond-book is not able to work with 
*.tex, *.html or *.texi input files at all (the bug is that when --output is 
given, then that wrong error message is triggered and lilypond-book refuses to 
There is also no workaround for this, except discouraging the use of these 
three extensions at all for input files :(

> I have to copy an old version of
> lilypondbook into every new release in order to get
> a working version.  We can't expect users to do that.

No, of course not. I'm thinking about how to make l-p work for both cases.

Reinhold Kainhofer, address@hidden,
 * Financial & Actuarial Math., Vienna Univ. of Technology, Austria
 *, DVR: 0005886
 * LilyPond, Music typesetting,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]