[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GUB target_cpu error

From: Neil Puttock
Subject: Re: GUB target_cpu error
Date: Sun, 28 Nov 2010 20:59:45 +0000

On 27 November 2010 10:03, Graham Percival <address@hidden> wrote:

> I'd rather not simply revert it, since it seems like a good
> feature.  How are you declaring target_cpu ?  Did you succeed in
> building GUB from scratch?  if you can build it from scratch and I
> can't, then there must be something weird about one (or both) of
> our computers.  Were you using a 64-bit OS on 64-bit hardware?
> I'm running a 32-bit ubuntu on 64-bit hardware, which could
> potentially be the problem.  IIRC Jan uses a 64-bit OS, so if you
> used that too, it would explain why neither of you experienced
> this problem.

I'm on 64-bit and still get the same error.  The attached patch seems
to fix the problem, though it leads to another issue: Valentin's
original patch uses shopt, which doesn't work with my default shell
command; If I do the following,

sh ~/gub/uploads/

I get this:

/home/neil/gub/uploads/ 9: shopt: not found

lilypond installer for version 2.13.41 release 0,
i686 build.
For a list of options, abort (^C) then do:
sh /home/neil/gub/uploads/ --help

Warning: this build is not optimized for your architecture;
please install a x86_64 build instead.

Press C to install the program anyway (not recommended),
E to only extract the program files, or any other key to exit.
read: 93: Illegal option -s

whereas using bash works.


> - Graham
> _______________________________________________
> lilypond-devel mailing list
> address@hidden

Attachment: 0001-Fix-architecture-compatibility-check.patch
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]