[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: compiling documentation

From: Federico Bruni
Subject: Re: compiling documentation
Date: Sat, 02 Jul 2011 18:33:41 +0200

Il giorno sab, 02/07/2011 alle 16.31 +0100, Phil Holmes ha scritto:
> Well - it looks as if it's failing trying to run lilypond on 
> /input/regression/midi/
> I can offer 2 suggestions.  Instead of make distclean, simply delete
> your 
> build directory and then recreate it using the instructions in the CG.
> Then 
> make and make doc.  If it still fails, try running lilypond against 
> /input/regression/midi/ - if it fails, then there's an
> error 
> in the regression tests. 

I deleted the build dir and compiled again from scratch, but I get the
same error.

Running lilypond on that file works fine:

out/bin/lilypond ../input/regression/midi/ 
GNU LilyPond 2.15.0
Interpreting music... 
Preprocessing graphical objects...
Interpreting music... 
MIDI output to `key-initial.midi'...
Finding the ideal number of pages...
Fitting music on 1 page...
Drawing systems...
Layout output to `'...
Converting to `./key-initial.pdf'...
success: Compilation successfully completed

But I must say that I ran the same command before compiling from scratch
and the compile was not always successful, even using the binary from

$ lilypond-master/build/out/bin/lilypond
GNU LilyPond 2.15.4
Processing `lilypond-git/input/regression/midi/'
Interpreting music... 
Preprocessing graphical objects...throw from within critical section.

Annullato = canceled (?)

It looks like a sporadic error when I run it alone.
When I compile I get an error for sure.

I'm lost, hope you have some other ideas :-)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]