[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Re^2: Font problem, Xdvi, quite urgent.

From: Mats Bengtsson
Subject: Re: Re^2: Font problem, Xdvi, quite urgent.
Date: Mon, 15 Oct 2001 11:40:04 +0200

> Mats wrote:
> > Do you use the environment variable settings in
> > lilypond-1.x.xx/buildscripts/out/lilypond-profile
> > (installed in /etc/profile.d/ if you install the Lilypond RPM)?
> > I myself use the alternative described in
> > to link the Lilypond
> > MF directory to the local texmf tree,
> > /usr/share/texmf.local/fonts/source/lilypond.
> I use, but the other method doesn't work, either.

Hmm, you say you use, I hope you don't mean the
file buildscripts/ That file is just a template, 
the correct paths are found in buildscripts/out/lilypond-profile, 
assuming that you installed Lilypond using `make install'.

Anyway, if you go for the first solution (environment variables), 
the main thing is that the variable $MFINPUTS points to the 
directory where the feta*.mf files reside. If it is set correctly, 
'kpsewhich' should return the full path to the
file. The problem with this solution is that the generated .tfm
and .*pk files may end up in the current working directory (depending
on how your teTeX installation is configured). However, both Lilypond, 
xdvi and dvips should be able to find the necessary fonts. Note that
$MFINPUTS should end or begin with a colon, so TeX finds the default
fonts as well. 

If you prefer the solution described in the FAQ, see to it that 
$MFINPUTS is not defined and that you have ran the command
'texhash' as root. Once again, the command 'kpsewhich'
should return the full path where it finds the file. 

> > If you get it right, you should be able to run e.g.
> > lilypond
> > tex myfile.tex
> > xdvi myfile.dvi
> > dvips myfile.dvi
> That is the problem, I don't get it right. And even if I kill off all the 
> .tfm and pk's on my machine, I still have the same problem. Something always 
> hangs around. Is there a way to _completely_ start over with the fonts? I'd 
> gladly do that, I have to get some work done.

The kpsewhich command is your friend when you want to find out 
which font file is actually found.

> > An alternative for dvips is to use the Type1 fonts and say
> > dvips -Ppdf
> > If you make PDF files, that's the preferred option, but of course
> > you should have a working font setup anyway.
> >    /Mats
> everything tried, nothing works. I'd be glad to know a bit more about 
> Lilypond's font handling, (read: what goes where at what time).

Both Lilypond and TeX+friends use the Kpathsea library, run
'info kpathsea' to learn more. There's also some general info
in the teTeX manual 'texdoc TETEXDOC'. As long as the .mf files
are found, all necessary .tfm and .*pk files are generated on the
fly if they can't be found.

The reason that you don't get the errors when you run ly2dvi is
that it sets the search paths internally. The problem with this
nice solution is that is sometimes hides the true setup problems
which have to solved anyway if you want xdvi and dvips to work.
By the way, does 'ly2dvi -P' provide functional PS file?

If you still can't resolve the problems, please send me a private
email with the exact commands you run and the corresponding output. 
Also, include information on where you have Lilypond installed and
how you have set the necessary environment variables.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]