[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Almost built but not quite. Suggestions?

From: Jack J. Woehr
Subject: Re: Almost built but not quite. Suggestions?
Date: Sat, 15 Dec 2001 17:12:39 -0700

Jan Nieuwenhuizen wrote:

> > Each time bison ran, with the commands:
> >
> >      bison parser.yy
> >      mv out/
> >
> > The file would be missing. So I descended manually and ran
> > bison there and then everything seemed okay.
> Strange, what was the error you got; and what bison command did you
> use that succeeded?  It looks like both commands
> were successful, and that's the cause of the link failure:

Well, I started again from scratch.

Here is the first failure:

     bison -d parser.yy
     mv out/parser.hh
     mv: cannot access
     make[1]: *** [out/parser.hh] Error 2
     make[1]: Leaving directory 

So I go into ./lily and look and here's the problem:

address@hidden:/usr/local/src/various/lilypond-stuff/lilypond-1.5.25/lily]$ ls 
-l parse*
     -rw-r--r--   1 jax      staff     125227 Dec 15 17:01
     -rw-r--r--   1 jax      staff       2912 Dec 15 17:01
     -rw-r--r--   1 jax      staff      44850 Dec  1 07:34 parser.yy

Apparently the mv operation fails because bison isn't generating the file names 
expected by the makefile.

I think I obscured the issue by re-running bison by hand.

For right now I will very carefully mv to out/parser.hh and 
continue trying to build.

Jack J. Woehr      # The man who carries a cat by the tail
Senior Consultant  #   learns something that can be learned
Purematrix, Inc.   #      in no other way. #         - Mark Twain

reply via email to

[Prev in Thread] Current Thread [Next in Thread]