[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Lilypond can't find its fonts

From: Benjamin Esham
Subject: Lilypond can't find its fonts
Date: Sun, 1 Aug 2004 17:14:58 -0400

(This is being cross-posted to both lilypond-user and fink-users. Please
reply to only one of these lists.)

I'm using LilyPond 2.3.8 (package lilypond-unstable 2.3.8-1) with fink
0.20.6 and the latest package descriptions, and my OS is Mac OS X.3.4.
I'm having all kinds of trouble with Lily.  For starters, whenever I try
to process a file I get this:

| paper output to `'...
| warning: lily-guile: Can't find PFA font "ecbx10"
| warning: lily-guile: Can't find PFA font "ecbx12"
| warning: lily-guile: Can't find PFA font "eccc10"
| warning: lily-guile: Can't find PFA font "ecrm10"
| warning: lily-guile: Can't find PFA font "ecti7"

There are some oddities in the output.  First, the fonts used for the
header all appear as some monospaced font (Courier?).  I guess this is
expected, since Lily couldn't find the font files.

The next oddity is the kerning of the fonts in the PDF output. All of the
text in the header, as well as textual dynamic markings, is squished
together and is mostly unreadable.  Oddly, a space character still seems
to produce the same amount of white space; it's just the letters within a
word that are compacted together.

I think one or more of fink's TeX-related packages may be at fault for
this next part (and hence the cross-posting).  The PDF is only squished
like this when the PostScript output is run through ps2pdf (either
automatically by Lily or manually).  If I open the PostScript file in
Preview (and the system converts it to PDF), the letter spacing is normal.

I then tried to install lilypond-unstable-2.3.9-2, and when I tried to
process a file I got this:

| error: parse error, expecting `DOUBLE_ANGLE_OPEN' or
| brass = \notes \relativ
|                        e c' {

I assumed that this was just a change in syntax causing problems, but
there was also this line at the end:

| Interpreting music... error: can't find `feta20.afm'
| Music font has not been installed properly.  Aborting

So it looks like the fonts aren't properly installed by the new package

Can anyone shed any light on these problems?  Many thanks!

Benjamin D. Esham      {
address@hidden      }      AIM: bdesham 1 2 8
Wikipedia, the Free Encyclopedia -

reply via email to

[Prev in Thread] Current Thread [Next in Thread]