[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

(font-) problem with lilypond-snapshot 2.4.0

From: Roland Goretzki
Subject: (font-) problem with lilypond-snapshot 2.4.0
Date: Thu, 4 Nov 2004 15:41:06 +0100
User-agent: Mutt/

Hi at all,

after installing lilypond-snapshot 2.4.0 from Pedro Kroegers site
on a never-online-host with dpkg as follows:

    dpkg -i ec-fonts-mftraced_1.0.7-1_all.deb
    dpkg -i lilypond-snapshot_2.4.0_i386.deb

and both worked successfully, I got the following error message
after running lilypond-snapshot:

    address@hidden:~/noten/2.4.0-lilypond$ lilypond-snapshot --ps 
    Now processing `'
    Interpreting music... [8][13]
    Preprocessing graphical objects... 
    Calculating line breaks... programming error: Must have
    Modified_font_metric for text.
    Continuing; crossing fingers
    ((feta26 parmesan26) . 0.611950149526611)[3][6][9][12][13]
    programming error: I'm empty. Can't align on self
    Continuing; crossing fingers
    Interpreting music... 
    MIDI output to `test.midi'...
    Track ... 
    Layout output to `test.tex'...Converting to `test.dvi'...
    Converting to `'...

And the missfont.log contains the line:

    mktexpk --mfmode ljfour --bdpi 8000 --mag 0+6832/8000 --dpi 6832 

My tex-installation:

    address@hidden:~/noten/2.4.0-lilypond$ tex --version
    TeX (Web2C 7.4.5) 3.14159
    kpathsea version 3.4.5
    [ ... ]

So is this enough to help me?
(If not, at the bottom there will follow a report, what I tried to fix.)

Thanks in advance!

Best Regards           Roland

As Han-Wen Nienhuys wrote on Sat, 30 Oct 2004 12:16:21 +0200
to Cameron Horsburgh:

    byrd:~/usr/src/lilypond$ kpsewhich ecrm10.pfa

I did:

    address@hidden:~/noten/2.4.0-lilypond$ kpsewhich ecrm10.pfa

So I think, there IS NOT the problem ...

%%  ----------------------------------------------------------------  %%

As Mats Bengtsson wrote on Mon, 01 Nov 2004 11:07:47 +0100
to Alexandre Beneteau:

    What LilyPond does internally, is to call dvips with the following
    dvips -Ppdf -u+lilypond -u+ec-mftrace filename.dvi

    What happens when you try this manually?

With this command I got

    This is dvips(k) 5.92b Copyright 2002 Radical Eye Software
    ' TeX output 2004.11.04:1507' ->
    kpathsea: Running mktexpk --mfmode ljfour --bdpi 8000 --mag 0+6832/8000
    --dpi 6832 feta-braces-f
    mktexpk: Mismatched mode ljfour and resolution 8000; ignoring mode.
    mktexpk: Can't guess mode for 8000 dpi devices.
    mktexpk: Use a config file, or update me.
    kpathsea: Appending font creation commands to missfont.log.
    dvips: Font feta-braces-f not found,  using cmr10 instead.
    dvips: Design size mismatch in font feta-braces-f
    dvips: Checksum mismatch in font feta-braces-f
    <>. <ecrm6.pfa><feta-nummer8.pfa><feta18.pfa><ecbx12.pfa>

and no better result. :-(

%%  ----------------------------------------------------------------  %%

And also as Mats Bengtsson wrote on Mon, 01 Nov 2004 11:07:47 +0100
to Alexandre Beneteau:

    The command
    kpsewhich -format='PostScript header'
    should return something like

With this command I got:


I don't know, if this difference is important or not ...

reply via email to

[Prev in Thread] Current Thread [Next in Thread]