[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building Lily

From: Mats Bengtsson
Subject: Re: Building Lily
Date: Tue, 14 Dec 2004 10:43:42 +0100
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040913

LinuxChiq wrote:
./configure //ok
make // too many errors, gave up
make install // too many errors, gave up

and most interesting:
linux:/home/trinity/lilypond/src/lilypond-2.4.2 # buildscripts/
-bash: buildscripts/ Permission denied

Use buildscripts/out/clean-fonts ! I don't understand why the
INSTALL.txt files mentions the wrong file.

However, your error message should have nothing to do with
old font files.

First of all, you didn't say exactly what file you used to test the
installation. I hope you follow the steps at
and didn't try some large example. Also, I hope you made sure that
the example was for version 2.4.x and not for some other file.

If that doesn't help, when you run the command
lilypond --help --verbose
you should see something like


at the end. Please check that all the files in
where changed at the time when you ran 'make install'.

Also, I hope you didn't use any strange flags to the configure command
or set the environment variable LILYPONDPREFIX.


linux:/home/trinity/lilypond/src/lilypond-2.4.2 # whoami

There was no output at all from

Any suggestions as to how I might proceed would be very much appreciated.


On Thu, 09 Dec 2004 09:18:36 +0200, Tapio Tuovila wrote

LinuxChiq wrote:

I gave make install a try, copied an example file from the lilypond homepage,
and gave it a shot. Here's the result:

GNU LilyPond 2.4.2
Processing `/home/trinity/'
Interpreting music...
warning: lily-guile: installation problem: deprecated encoding requested:

Any suggestions at this point?



Sorry, I can not remember for sure which packages were missing. Suppose they were 1) something-dev ? 2) some newer versions (of some gnome-related software? pango? -for some reason I've installed pango-1.5.2 from source; possibly for trying --enable-gui)

- Did you do ./configure make make install ?? (This was what Mats suggested, I think) - Or did you try make install after make all? - And did you get any decent output from Perhaps you can ignore the above-mentioned lily-guile -warning? - Sure you did this buildscripts/ if you did an upgrade of lilypond?? - And of course you did source the buildscripts/out/lilypond-profile,
didn't you?

(BTW, I did build texinfo 4.7 from source, can be done on Suse as well, but this might also have needed some extra packages ... maybe there is something weird going on in my installation of Suse??)

best regards,

lilypond-user mailing list

Open WebMail Project (

lilypond-user mailing list

        Mats Bengtsson
        Signal Processing
        Signals, Sensors and Systems
        Royal Institute of Technology
        SE-100 44  STOCKHOLM
        Phone: (+46) 8 790 8463                         
        Fax:   (+46) 8 790 7260
        Email: address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]