[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building Lily

From: Tapio Tuovila
Subject: Re: Building Lily
Date: Thu, 23 Dec 2004 21:59:28 +0200
User-agent: Mozilla Thunderbird 1.0 (X11/20041207)

LinuxChiq kirjoitti:
./configure //ok
make // too many errors, gave up
make install // too many errors, gave up

and most interesting:
linux:/home/trinity/lilypond/src/lilypond-2.4.2 # buildscripts/
-bash: buildscripts/ Permission denied
linux:/home/trinity/lilypond/src/lilypond-2.4.2 # whoami

There was no output at all from

Any suggestions as to how I might proceed would be very much appreciated.

Sorry, I can not remember for sure which packages were missing. Suppose they were 1) something-dev ? 2) some newer versions (of some gnome-related software? pango? -for some reason I've installed pango-1.5.2 from source; possibly for trying --enable-gui
Hello, Raven

today I installed lily 2.4.2 on my daughter's computer on suse 9.1. As you may already know, I had some error message about pfa-fonts, but that could be ignored. As I thought about your recent problems, I installed lily keeping texinfo 4.6. I compiled FontForge (recommended for mftrace on Han-Wen Nienhuys' site) and that needed xfree-devel, I think. Also python-devel was needed, but I think this was all. Make ended //too many errors, gave up and so did make install, but nevertheless I did get a fully functional install of Lilypond.

In ..../lilypond2.4.2/buildscripts/out I did "mv lilypond-profile /etc/profile.d/" and relogged. Then tried ..../lilypond2.4.2/input/ and it worked OK.

This installation is without documentation because of texinfo 4.6, but apart from that it should be all right.

Hope this helps, if you still had problems.

Best wishes,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]