[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building 2.5.20

From: Daniel Johnson
Subject: Re: Building 2.5.20
Date: Fri, 22 Apr 2005 21:58:52 -0700
User-agent: Mozilla Thunderbird 1.0.2 (X11/20050401)

I had the same problem.  From what I've read, the flex API has changed
since 2.5.4a.  Here's what I did to fix it:

sed -i -e 's:\$\(FLEX\) :\$\(FLEX\) -l :' stepmake/stepmake/c-rules.make

The "-l" flag tells flex to behave like old-school lex.  It seems like
the configure script should take care of this, though.

Jonatan Liljedahl wrote:

>I've just downloaded 2.5.20 and am trying to build it. 
>It bails out on out/ with:
>out/ In member function `virtual int Lily_lexer::yylex()':
>out/ error: `yy_current_buffer' undeclared (first use this
>   function)
>I can see that the configure scripts checks for yy_current_buffer and
>says "no".
>This was no problem with 2.5.18.
>I'm using Flex 2.5.31.
>/Jonatan    -=( )=-

reply via email to

[Prev in Thread] Current Thread [Next in Thread]