[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Upgrading to 2.6 Help

From: Tim Sawyer
Subject: Re: Upgrading to 2.6 Help
Date: Sun, 13 Nov 2005 20:12:42 +0000
User-agent: KMail/1.8.1

Cheers for that.

Next problem - my music now goes through lilypond book successfully, but I 
don't seem to be able to process the output.

I have a script that does:

rm -r build
mkdir build
cp volume2.tex ./build
cd build
lilypond-book -V --psfonts -o output volume2.tex
cd output
latex volume2.tex

lilypond-book completes with:

Extracted feta-alphabet13
Extracted CenturySchL-Ital
Writing fonts to volume2.psfonts

DVIPS usage:
    dvips -h output/volume2.psfonts output/volume2.dvi

Looking through the lilypond-book output, there are no errors but there are a 
couple of warnings.  The "latex volume2.tex" command gives this output:

This is TeX, Version 3.14159 (Web2C 7.4.5)
LaTeX2e <2001/06/01>
Babel <v3.7h> and hyphenation patterns for american, french, german, ngerman, 
ohyphenation, loaded.
Document Class: book 2001/04/21 v1.4e Standard LaTeX document class
No file volume2.aux.
No file volume2.toc.
[1] [2]
Part 9.
[1] (./lily-109005405-systems.tex
! Undefined control sequence.
l.1 \includegraphics

If I try to run lilypond-book a second time (just that single command), I get 
an odd error:

address@hidden build $ lilypond-book -V --psfonts -o output volume2.tex
lilypond-book (GNU LilyPond) 2.6.4
lilypond-book: error: Output would overwrite input file; use --output.
Traceback (most recent call last):
  File "/usr/local/bin/lilypond-book", line 1620, in ?
    main ()
  File "/usr/local/bin/lilypond-book", line 1586, in main
    chunks = do_file (file)
  File "/usr/local/bin/lilypond-book", line 1446, in do_file
    ly.exit (2)
  File "/usr/local/share/lilypond/2.6.4/python/", line 139, in exit
    raise _ ('Exiting (%d)...') % i
Exiting (2)...

Can someone point me in the right direction?  I ideally want PDF output but 
always went through dvi with version 2.0.



On Sunday 13 Nov 2005 18:21, Han-Wen Nienhuys wrote:
> Tim Sawyer wrote:
> > I'm trying to upgrade from 2.0 to 2.6, and I'm having trouble.
> >
> >
> > Anyone any ideas?  convert-ly seems to output it the same as it went in.
> Check out the manual section on drum notation. There have been some
> syntax changes.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]